d7e2c0a924
Will this ever change? No like likely, but I do think that this is the correct way to do this.
35 lines
718 B
Nix
35 lines
718 B
Nix
{ config, lib, pkgs, user, ... }:
|
|
let
|
|
this = config.my.application.kdeconnect;
|
|
graphical = config.my.graphical;
|
|
in
|
|
with lib; {
|
|
options = {
|
|
my.application.kdeconnect.enable = mkOption {
|
|
default = graphical.enable;
|
|
type = with types; bool;
|
|
};
|
|
};
|
|
|
|
config = mkIf this.enable {
|
|
# home-manager.users."${user.name}" = {
|
|
# services.kdeconnect = {
|
|
# indicator = true;
|
|
# enable = true;
|
|
# };
|
|
# };
|
|
|
|
# networking.firewall = {
|
|
# allowedTCPPortRanges = [{
|
|
# from = 1714;
|
|
# to = 1764;
|
|
# }];
|
|
# allowedUDPPortRanges = [{
|
|
# from = 1714;
|
|
# to = 1764;
|
|
# }];
|
|
# };
|
|
programs.kdeconnect.enable = true;
|
|
};
|
|
}
|