d7e2c0a924
Will this ever change? No like likely, but I do think that this is the correct way to do this.
17 lines
522 B
Nix
17 lines
522 B
Nix
{ config, home-manager, lib, pkgs, user, ... }: {
|
|
imports = [ home-manager.nixosModules.home-manager ];
|
|
home-manager = {
|
|
useGlobalPkgs = true;
|
|
useUserPackages = true;
|
|
users."${user.name}" = {
|
|
# You can update Home Manager without changing this value. See
|
|
# the Home Manager release notes for a list of state version
|
|
# changes in each release.
|
|
home.stateVersion = "21.11";
|
|
|
|
# Let Home Manager install and manage itself.
|
|
programs.home-manager.enable = true;
|
|
};
|
|
};
|
|
}
|