d7e2c0a924
Will this ever change? No like likely, but I do think that this is the correct way to do this.
20 lines
519 B
Nix
20 lines
519 B
Nix
# Define a user account. Don't forget to set a password with ‘passwd’.
|
||
{ config, lib, pkgs, user, ... }: {
|
||
users.users = {
|
||
root.initialPassword = "noreallychangemenow";
|
||
|
||
"${user.name}" = {
|
||
description = "${user.description}";
|
||
extraGroups = [ "wheel" "systemd-journal" ];
|
||
initialPassword = "nixos";
|
||
isNormalUser = true;
|
||
shell = pkgs.zsh;
|
||
};
|
||
};
|
||
|
||
home-manager.users."${user.name}".home = {
|
||
username = "${user.name}";
|
||
homeDirectory = "/home/${user.name}";
|
||
};
|
||
}
|