This repository has been archived on 2023-08-08. You can view files and clone it, but cannot push or open issues or pull requests.
nil/modules/lang/nix.nix

17 lines
341 B
Nix

{ config, lib, pkgs, ... }:
let
this = config.my.lang.nix;
graphical = config.my.graphical;
in with lib; {
options = {
my.lang.nix.enable = mkOption {
default = graphical.enable;
type = with types; bool;
};
};
config = mkIf this.enable {
environment.systemPackages = with pkgs; [ nixfmt rnix-lsp ];
};
}